Help Please! Crypto lost during transaction from Metamask to Trezor

Hello, I could really do with some help please!

I had some Polygon (Matic) on my Trezor via Metamask and I decided to transfer them directly to my Trezor as I thought they were supported on the Ethereum network. I think I may have misunderstood the relationship between the networks. I had previously managed to move Shiba and I guess got too confident as I am still a newbie lol.

The transaction worked and clearly shows the coins were received in my wallet on Etherscan but I can’t find them on my Trezor now.

Is there a way for me to retrieve them?
Thank you :slight_smile:

Hi @Tarn93

If you have transferred your tokens on Polygon network you won’t be able to access those using Trezor Suite because it is not natively supported by this interface.
Since it is EVM compatible network the firmware supports it though so you just need to use Trezor with 3rd party app in order to access your funds and manage operations with them.

The easiest would be to use MEW. So connect your Trezor, select the address where you have sent your funds to and choose desired network (as shown on the screenshot below):

Altenratively you can use MetaMask and set custom RPC manually or use that sets it up for you.

Check out this earlier post as it may help you

How to add MATIC and AVAX to Trezor One - #2 by forgi.

hope it helps :four_leaf_clover:

1 Like

Thank you so much. Can I just confirm I have understood correctly please

Originally I paired my Trezor with Metamask and transferred my MATIC between MM and my Trezor (no problem).

I then decided to transfer my MATIC directly to Trezor from MM not realising it wasn’t supported (although I originally understood that lol).

I understand about MEW but am I understanding that I should still be able to see my MATIC in Trezor using Metamask differently as you explained?

Many thanks

This network is supported by Trezor (just Trezor Suite interface don’t support it).

Yes your tokens should be accessible (and manageable) also using MetaMask even when being on the addresses derived by Trezor when correct Network is added/set.

Thank you, I have tried your suggestions but I still can’t view the coins. I must be doing something wrong.

I sent the coins on the Polygon network from MM to Trezor Ethereum account (using that address). When I connect with MEW I can’t find the address and have scrolled through hundreds and nothing on MM apart from the original transaction which shows as successful and on the polygonscan.

How frustrating! Can you think of anything that I might be doing wrong? Is there a search area on MEW rather than scrolling do you know?

Thanks again

Hi Tania,

regarding to what you have described you are definitely accessing wrong wallet by either using different seed (device) or passphrase (or both).

Because when the same recovery seed is used and the same passphrase is entered (if enabled and used), the same wallet is accessed. There is no exception.

It always generates the same wallet including the same accounts having the same addresses in the same order. The public-key cryptography ensures it generates always the same result.

Thus in order to access the desired address you have to use exactly the same passphrase (which I believe is your issue) as you did when you used that address in the first place.

To access this hidden wallet repeatedly, you will have to use the exact same passphrase in combination with the recovery seed on the device. Using the same seed with a different passphrase will generate a different wallet. Using a different seed with the “correct” passphrase will generate a different wallet.

Mistyping the passphrase will generate a completely new wallet. There is no such thing as an “incorrect passphrase”, so whatever you provide as your input will be used in the process of deriving a wallet.

Also, please note that some users chose random input as a passphrase without paying much attention to it, without realizing that they will have to use exactly the same input/password to access the same wallet repeatedly.

From my experience sometimes users use also their PIN code, password to enter 3rd party standalone wallet/extension such as MetaMask or even the recovery seed.

Thank you, I don’t think I am explaining myself properly. I appreciate your patience and help.

I don’t have any problem accessing my Metamask account that I paired with Trezor. It shows the transaction from my Metamask/Trezor account to my Trezor Suite Ethereum account address. This also shows on Polygonscan.

However, what ever I try I am unable to find the ETH address connected with my Trezor suite under the list of addresses in Metamask or MEW.

I only have one recovery phrase and passphrase with Trezor. I have tried the Metamask recovery phrase (although I don’t need it as it lets me in with my password) also I have used the PIN when Trezor prompts me. Should I be using the Trezor suite recoveryphrase in the Metamask app?

I can see the original Trezor address inside of Metamask but it doesn’t give me the option of the ETH address from inside Trezor suite (within Metamask).

I hope this makes sense and thanks again for your help

This only confirms what I wrote one post above. I still believe that you are not accessing the same wallet (when using 3rd party interface) because the same addresses are displayed/accessed when the same ‘formula’ that consists of unique combination of recovery seed and passphrase is entered.

No matter what interface is being used (as the address is derived from the private key that is always securely kept on Trezor device and is represented by your recovery seed thus can be recovered anytime).

Please also see following video:

Also regarding 3rd party wallets in general:

When using third-party apps, beware, some of them create their own default wallet, different from a Trezor generated one. (For recovering such wallet you would need a recovery seed related to this wallet which is different from Trezor generated wallet.)

Once you initialize MetaMask wallet, there is a default account created (the red one in the picture). If you wish to use it, then you need to keep your MetaMask seed phrase to recover and access this account whenever needed. This account is not a part of Trezor wallet.

On the contrary, there are Trezor accounts (the yellow and the blue one in the picture). The same accounts are generated in MEW, Trezor Suite etc. These are Trezor generated accounts and can be recovered only by using Trezor recovery seed.

You can always conveniently check if the address you are trying to find is part of the wallet you are currently accessing by using following tool:

Thank you for explaining this, I am very new to crypto and finding the info hard to follow. I have one final question please following on from your explanation and a possible reason for my problem.

When do I use the recovery phrase for the Trezor1 account. Is this before I sign into Metamask or something that Trezor would prompt me to do when connecting my Trezor. So far I have only used the recovery phrase for MM on the sign in the extension. Or when connecting Trezor it only asks me for my PIN.

I have also found out that my other Trezor coins are not showing because they are in the Standard Wallet. I understand that I need to transfer these to the Hidden Wallet in order for them to be visible in MM. Is this correct please?

If this is the issue and possible reason I can’t view the coins, then this might explain why I can’t view the lost MATIC as I sent it to the Standard Wallet Ethereum address in Trezor Suite. How can I transfer this to the hidden wallet when I can’t see MATIC in the Standard Wallet, if that makes sense?

Thanks again, I am sure you are getting frustrated with me by now lol

I have found my MATIC!!! This might help other newbies.

If you send unsupported coins to your Ethereum account in the Trezor standard wallet (not the hidden wallet) you need to choose the Ethereum mainet on the Metamask sign in page on the extension (once paired with Trezor)… Go to ‘Connect hardware wallet’ under ‘Import Account’. After Trezor asks you for your PIN, it will prompt you to put in your passphrase. You leave it blank to acces your Default wallet (also called your Standard Wallet).

Once in Metamask, choose the network your coins are associated with, in my case it was Polygon for MATIC. Or you can probably choose that network at the top before you sign into MM.

Hey presto, there were my missing MATIC coins that I had sent from my Metamask Trezor 1 account, to my Standard Trezor Wallet. Not so obvious to find, especially as a newbie lol.

Thank you for trying to help me, I appreciate it.

1 Like

I will just clarify that MATIC tokens are supported (by Trezor firmware) you just won’t be able to see them using Trezor Suite.
The reason is the backend that is used. However there is several 3rd party apps that can be used as an interface to see those tokens once you connect your Trezor device and access right wallet.

Also, just for the future reference: If you enter an empty passphrase (no passphrase at all), the device will proceed exactly as if the passphrase feature had not been activated at all, and generate a wallet from your recovery seed stored on the device.

Anyway, I am glad that you were able to find your tokens :wink:

1 Like

Hello MichalZ,

If my brother logs onto Trezor Suit and he can see a green tick above the words Passphrase enabled
does that mean he has created a Hidden Wallet with a passphrase?

Screen shot attached.