Having a firmware update problem and not being able to test recovery seed

Corresponding with Trezor support for close to 2 months without resolve.

Wanted to first check seed but when suite is run it wants to update Trezor 1
firmware from 1.6.0 to 1.6.3. When I try to opt out of the update suite shows Device detected in incorrect state and device has firmware that is no longer supported.

I did try to update firmware before I realized I should do a dry run ( a few days before seed).

I ran suite and program (suite) sees Trezor 1
Wants to update firmware from 1.6.0 to 1.6.3
Disconnect trezor and reinsert holding both buttons

This is the point in the program it stays at ( Boot loader mode screen)
Serial # and loader version on trezor display.
Have to close suite to exit after waiting more than 10 minutes.

System Information
Trezor 1 has loader 1.3.2
Installed Trevor Suite
Updated Windows 10
NO VPN running
Kaspersky virus scanner is running
NO other programs running on laptop, minimum programs are installed on pc
No devices other devices except Trezor using USB ports. Tried both ports.
Ran update with same outcome multiple times with multiple pc reboots.

Couple additional questions
Will I be able to test seed form the Web wallet program or will it be the same situation?
Does updating Trezor 1 problem kinda sound like a Bridge file issue?

Thanks for any help, MikeV

Hi @mikev

To check your recovery seed prior to old firmware update, try using our older Trezor Wallet, available from https://old-wallet.trezor.io/

Next, make sure you are running Trezor Bridge 2.0.27. Check it’s running properly, seek for “trezord” process in your task monitor. Also, check Trezor Bridge Status, available from

Then, access bootloader mode again while connecting to Trezor Wallet https://wallet.trezor.io/#/ or the older Trezor Wallet https://old-wallet.trezor.io/

Please, let us know how did it go.

Thank you SOO very much for the reply and the great info. I WILL let you know. TNX again MikeV

I went to old-wallet using Chrome browser. Plugged in Trezor and clicked connect to device.
A box came up and the line said Trezor -paired. Clicked on it and then selected connect. Box closed and was back at main wallet page. I could not select anything, items were the same as when I first accessed the page before plugging trezor in. Not sure what I’m missing here. Windows did signal with beep when Trezor inserted and removed. Thanks MikeV.

Since Chrome is using WebUSB, please try Firefox relying on Trezor Bridge instead.

Ok will load it. Just a few more bits of info. With old wallet web page open there is NO TREZORD process running in Task Manager. Tried to access Trezor Bridge Status site but got message refused to connect. Do you want me still to get FireFox or should I try Bridge software at bottom of old wallet page. Please advise, Thanks Mikev

Sorry forgot to say have BRAVE browser installed if that would work rather than Firefox.

If there is no trezord process, and you are getting no results on, then Trezor Bridge is either not installed or doesn’t run properly. Reinstall it, available from https://wallet.trezor.io/#/bridge. Then, try it again, please (preferably with both supported browsers; Chrome and Firefox in incognito/privacy mode).

Sorry for the miscommunication on my end. I will follow what you suggest. tnx mikev

Hi pavel. FYI update. Reinstalled Trezor Bridge - Successful!
Ran status and log generated fine - Successful again!
Did above using Chrome in cognito mode.
Plan on checking recovery seed in next few days.
Many thanks, Mikev

1 Like

Sorry so long to get back. Test Trezor (have two) recovery seed per your instructions was 100% success! Have 2nd one that is most important. Will start this one today, hope firmware isn’t any older than previous one. Will find out soon, many thanks. MikeV

Sure thing, thanks for letting us know. Should you have any troubles along the way, reach out.

FYI - followed your examples using web based links and 2nd Trezor tested seed correctly and updated firmware flawlessly. My upmost appreciation for your knowledge and patience. Many Thanks. MikeV

Sorry to keep asking questions but forgot on last post. When I use Suite App and connect my second Trezor (one that holds Bitcoins) I see two accounts. Bitcoin #1 0 BTC and then the line Segwit Accounts and again Bitcoin #1 correct # BTC. I did have computer lockup when firmware was loading and had to abort, went into recovery, entered seed words and all looked fine. Since the second Bitcoin #1 shows the correct amount of BTC should I just use this one and not worry about the account that shows zero coins. My test Trezor has zero coins and only shows one Bitcoin #1 account did not think this was a good comparision. Thanks again. MikeV