Has my Trezor Model T been hacked?


I use my Trezor Model T with the Exodus software wallet.

I updated to the latest Exodus and then had to update the firmware on my Trezor Model T to firmware 2.5.1 using Trezor Suite on Windows 10.

I now have two problems that popped up with this upgrade:

Most alarming issue is that I tried to send 0.00163343 BTC to my trading exchange (TradeOgre). But every time Exodus asks me to confirm on the Trezor Model T, the Trezor is showing more than 100X the amount at 0.16401186 with a SEND address that is different than the one I pasted in Exodus!!

I have tried this several times and the Trezor is always showing a 100X mismatch and address mismatch. Very, very concerning. What is going on? Has the Trezor somehow been hacked via the firmware upgrade?!?! How can we trouble shoot and correct this problem?

One of my portfolios in Exodus has now vanished after completing both the Exodus update and Trezor firmware update! Exodus is only showing 1 of the 2 hidden wallet portfolios from my Trezor Model T. Previously, it always showed both portfolios from the Trezor Model T (in addition to the Exodus main portfolio itself). How do I get it to show that missing portfolio? Do I have to do something in Trezor Suite?

To complicate matters - for this second hidden wallet I do have the seed words. But the passphrase was a typo since the day I set it up. I had not been able to discover the correct passphrase again BUT this was always a long term project for me, to go through all the possible typos. At the very least I want to see that the portfolio is still there, as there were a few thousand dollars trapped in it. How do I restore the portfolio to Exodus/Trezor if I only have the wallet seeds for that second hidden Trezor wallet but not passphrase?


  1. your Trezor was not hacked, we have come across similar issue and it’s on Exodus side. They confirmed it and they are working on the issue. Please, contact them for more details.
    In the meantime do not send funds using Exodus, you can still use Trezor Suite.

  2. If you know you have wrong passphrase there is nothing you can do except find the correct one.

If you know at least the address you can check your funds anytime in a BTC explorer: https://btc1.trezor.io/

1 Like