Hang on Signing Transaction in suite from bech32 wallet ▫

Do I really have to tell you what’s happening? Many others posting online about the same problem but there is no solution (that works) that I can find anywhere.

Everything seems fine but when the wallet gets to signing transaction the progress circle goes exactly a quarter way around and hangs every time. I’ve tried new cables. restoring from seed. changing the screen pic (something someone online said that would fix it but it didn’t)

Support seems non-existent. Opened a ticket and received a reply that I might have to wait 20 days for a response.

Meanwhile I’m locked out of $20,000 WTF guys this is some serious asleep at the wheel bs.


Hi @jdb

Sorry to hear you have been experiencing such issues. Could you please send us your Ticket ID so we could prioritize your issue?

Thank you for your cooperation in advance.

Hi @pavel

I am having exactly the same issue as described above.

I have submitted a ticket, ID: 81308.

At the moment, I cannot seem to transfer any of my funds to any other address, as signing just keeps hanging! Using latest version of Suite, and latest firmware on Trezor Model T.

I have also tried wiping the device and restoring from seed - but the problem remains.

Please can you help as soon as you are able?