Failed tx Trezor to MM. Over and over and over

My handle says it all–I am just dipping a toe into Trezor.

I have been able to send both some ETH and two ERC-721 tokens of little value from my Metamask (MM) wallet to Trezor. Yay!

I cannot send either ERC-721 token back to MM.
I go on send, I put in my MM wallet address, I choose the token, choose send Max (value is always 0.[lots of zeroes]1).
I confirm it manually on my Trezor touchscreen.
I approve the gas. (Once or twice I’ve even bumped it higher, just to see if it’ll help.)
I click send.
I get the pending transaction box.
30-60 seconds later, transaction fails.
This has happened five times over the last two hours.

What am I doing wrong, folks? (I have tried bumping gas fee, no joy.)
Thanks very much.

Hi @TrezorNewb

Please note that Trezor officially does not support NFTs so this is out of scope of this forum.
I suggest you to have a look at following articles or contact MM support directly:

1 Like

Hi @TrezorNewb,

Should your issue has not been solved, kindly see my notes below.

I had same issue this morning. Same message ‘You declined the action in your wallet’. FYI, this is my chronology.

  1. Send small amount NFT to trezor on metamask to test
  2. Send back succesfully from trezor to metamask on opensea
  3. Send big amount of NFT to trezor on metamask
  4. Can’t send back my big amount of NFT to metamask

I found 3 alternative solutions on problem no 4 above, on this forum and reddit :

  1. Connect your trezor account to MyEtherWallet and send NFT from there
  2. Import your trezor seedphrase to other NFT supported wallet such as metamask, trustwallet, or other hardware wallet
  3. Update the firmware of trezor to the latest version

No 1 and 2 solution didn’t work for me. Eventually the easiest solution which is no 3 worked for me.

Hope you can solve the issue soon.

Happy to help should you have more question.

Thank you