Error updating firmware while using USB-C adapter to notebook

Initialize failed: hidapi: hid_error is not implemented yet, code: undefined

Here is what I get while trying to update the firmware. The bot recommended to plug USB in w/o an adapter, but this is the only notebook I have, it is MacBook Pro and it does not have any old USB slots. Only USB-C. The standard offered remedy is not applicable, as the Suite offers the only step - to install the firmware first, after that it is possible to proceed to recover. But the firmware cannot be installed (see the error above). What are my steps to recover? Thanks.

Hi @maxi,

first, please try to factory reset your Trezor. You need to connect your Trezor in bootloader mode first. In order to do that, swipe your finger across the screen while simultaneously plugging the cable into your Trezor Model T, or if you have Trezor Model One, connect it while using your index and middle finger to hold both buttons pressed.

After the device is connected in bootloader mode you should see the following screen in Trezor Suite:

Click on the green gear button to open the device settings:

Beware, a factory reset will completely erase your device, including firmware and your private keys. Therefore, make sure you have your recovery seed and passphrase (if used). No need to rezor worry about it if you initialize you Trezor for the first time


You can now click a factory reset button.

Please tick both boxes in the next pop-up window and confirm the action directly on your device.

You can reconnect your device and go to Trezor Suite then. Please follow the instructions to install the latest firmware, create your wallet, and set up a PIN.

In case you still see the same error message, you will need to use USB cable which allows you direct connection of your Trezor with a host device. You can also try to initialize you Trezor on a different computer.

1 Like