EIP 1559 Support

I am trying to interact with a dApp using Metamask (I have tried different browsers and all firmware/software is up to date) and continually get:

“Invalid transaction params: params specify an EIP-1559 transaction but the current network does not support EIP-1559”

The dApp support said it is an issue on Trezor’s side, is there any work around or setting to adjust for this? Thank you!

Had to downgrade to Metamask 9.8.4 and it worked, can’t wait for Model One to support EIP-1559!

It seems Trezor T also not working for EIP 1559

Just updated my trezor model t. Still does not support EIP-1559! What is going on with this company? Why are you not supporting the newest protocols on the eth network? You should’ve had this update ready before eip-1559 even went live, yet here we are 5 months later and my trezor becomes more and more useless everyday. I had to buy a ledger just to have a wallet that actually works, so my funds aren’t locked. There’s absolutely no reason someone should have to downgrade their metamask to use your product, it’s your responsibility to put out those updates in a timely fashion to coincide with network changes.
You’re losing customers because of your inability to keep your products properly up to date. This needs to be fixed immediately, at this point the trezor products are just a waste of money!!

Hi @cambuehl
Thank you for your feedback.

Trezor model T support for EIP-1559 was implemented in firmware update 2.4.2 (mid Septeber).
However, the corresponding functionality is missing on Metamask side:

Today’s update regarding this issue (EIP-1559) was related only to Model One FW:


Then why am I constantly getting this message: Invalid transaction params: params specify an EIP-1559 transaction but the current network does not support EIP-1559? Also, why is a trezor dev by the name of matejcik, on your forums telling people: “EIP-1559 for Trezor One will be included in next firmware update, which is currently scheduled for December 8th – that is, if everything goes right.” Obviously trezor 2.4.2 never supported eip-1559, and neither does the newest update. Your own developers have admitted this. You should be ashamed of yourself for closing this issue, it seems all you’re trying to do is make it difficult for new customers to see the problems that are associated with your devices. This is a major issue and I’m not the only one having this problem. It needs to be fixed! Downgrading metamask should not be a workaround you’re telling people to use, you need to upgrade your products!

I can complete these same transactions with my ledger without issues. Trezor does not work with eip-1559!

Because that’s correct.
I have also confirmed that in the post above.
The support of EIP-1559 in Trezor One FW was implemnted in today’s release.

Support of EIP-1559 for Trezor model T was implemented in the update 2.4.2 released on 16th September. However there is persisting issue on Metamask side.

I suggest you to have a look at Github issue #12130 that I shared.

Ok, then why am I and plenty of others still having issues not being able to do any transactions that require an EIP-1559 signature? Just because you say it, doesn’t make it true. I can show you screenshot after screenshot of messages stating that the transactions started with my trezor do not support EIP-1559 signature and cannot progress. Again, those exact same transactions go through flawlessly with my ledger. Rather than trying to argue and give a simple answer that, “it has been implemented”, how about you try to help us fix it, if it is indeed working as you say. As i’m not the only one stating that eip-1559 tx’s do not work with trezor. If it is working as you say, what needs to happen to make the trezor wallets useable?

@cambuehl TREZOR Try

Because the corresponding functionality is missing on MetaMask side as it has already been stated.
I understand that it is annoying but you have to address this issue to MetaMask as there is nothing else we can do on our end as support of EIP-1559 has already been implemented in Trezor T FW.

Please note that workaround is still to downgrade Metamask to pre-EIP-1559 version.

Downgrading is a terrible workaround, and is something you should definitely not be recommending. I guess ledger is the clear winner.