Dropped ETH transaction not return to my trezor wallet - help

Hi,
I send ETH from my trezor wallet via Trezor Suite and because I am beginner I made mistake with low fee. The transaction was pending for 14hours and after that has status DROPPED. It was 8 hours agou. No any ETH was return to my wallet! The send transaction is not visible in my wallet in trezor suit any more.
Please help me. I lost my ETH? Why is not visible in my wallet, why transaction is disaper?. Please help. Thank you

Hi @Moosa

It’s either confirmed, and your funds are spent, or it’s unconfirmed and nothing has changed.

Hi,
my ETH are gone from my wallet. Status of the transaction you can see in the attachment. Destination address received nothing.

I just try open web trezor suit and I can see this:

Hi @MichalZ
I still not see my ETH in my wallet. Desktop app suite does not show sent transaction and 0ETH, web suite show me sent transaction (previous screenshot) and 0ETH.
I use trezor suite to send ETH with automatic fee. I do not understand why trezor put so low fee.
But main issue here is: where is my ETH please, help me.

Could you please try sending a 0 ETH transaction to your own address with the same nonce and a higher gas price ? You have to do this via MetaMask as the nonce can’t be set in Trezor Suite.

@MichalZ I setup MetaMask and connect my eth wallet,I can see correct value on it! In the trezor I can see 0ETH in the MetaMask I can see 1ETH. Is it normall? Should I still test send 0ETH to my wallet? Thank you.

the most important is what’s on the blockchain (etherscan). So there is probably no need to cancel the transaction by sending 0ETH to yourself.
MetaMask and Trezor Suite are using different backends, that’s why you don’t see your funds in Suite as its backend might have not been updated properly.
Can you see your funds when you connect your Trezor to MEW as well?

@MichalZ What I did:

  • install MetaMask into Google Chrome
  • create MetaMask account
  • connet my Trezor and connect my ETH wallet
  • what I see now is correct funds
  • in trezor suite I see 0

trezor suite still 0
screen4

And on Etherscan I can see correct funds on my eth wallet.

Could you please try to reset the app in the Trezor Suite’s settings (at right up corner) ?

Hi @MichalZ
I did Reset app, I have version 21.11.2. The reset not help. Not visible the last problematic transaction in history and no any funds in my eth walllet. When I use web trezor suite in google chrome (delete cookies) (Trezor Suite) , I can see my funds! yeeha.
Should I uninstall and install agan desktop Trezor Suite? Or any tips how visble correctly my funds in desktop trezor? Big thank you for your help!

yes please, uninstall the Suite application and see if there is still folder called Trezor in the appdata.
If it is still there please delete it and install the Trezor Suite application again.

However I just want to stress that this is just the issue of the interface. Your funds are still on the address (as you can see on the blockchain explorer) of which you have the private keys kept on your Trezor.

If the problem will persist even after reinstalling the Suite, you can provide the log of the app so we could examine the issue in further details.

Big thank you @MichalZ , problem is solved.
For others with same issue and same low experience:

  • first step check your wallet address here: https://etherscan.io if you see your funds here, all is ok. If not, ask to to help this forum.
  • check you have latest versio of Trezor Suit
  • try eject HW wallet from the Trezor Suit app (top left menu) and connect again (it helps me)
  • try uninstall and install Trezor Suit app again

Again big thank to this forum and @MichalZ for support.

1 Like

Hello I have the same issue can you please help. I see the ETH in my Trezor address when using the https://etherscan.io but is not showing up in my Trezor suit wallet.

I follow the steps. I see the eth now. thanks.

1 Like