Default Wallet is no longer found - Metamask/Ronin


On the first day of using Trezor, I set up a new wallet in Metamask and Ronin, so far so good, I even made transfers to the Metamask wallet, this wallet:

The next day I needed to reinstall my browser and Metamask and Ronin, to my surprise my first wallet is no longer found, a new set of addresses is provided, that first one being:

Even if I do the process with the passphrase option on or off, in the suite application, the default wallet without inserting a passphrase is still the second wallet.

Where did my first wallet go?


When the same recovery seed is used and the same passphrase is entered (if enabled and used), the same wallet is accessed. There is no exception. It always generates the same wallet including the same accounts having the same addresses in the same order. The public-key cryptography ensures it generates always the same result.

So yo are either using different seed or passphrase (or both).

Mistyping the passphrase will generate a completely new wallet. There is no such thing as an “incorrect passphrase”, so whatever you provide as your input will be used in the process of deriving a wallet and its accounts.

If you have previously imported account from Standard (not passphrase protected/hidden) wallet then simply enter an empty passphrase (no passphrase at all), the device will proceed exactly as if the passphrase feature had not been activated at all,


I was able to solve the problem. Actually the secret phrase issue is a little confusing at first, but I managed to identify which secret phrase was used.

Problem solved.