Connect Hardware Wallet (Ronin) created an ronin account not inside Trezor - now can't access it

Good Day!

I used the connect hardware wallet in Ronin and successfully created an account in Ronin. I transferred my AXS SLP and ETH successfully from my old main account to this new Trezor account and I was able to log-in to Axie Infinity to set-up my email password etc.

I did it a second time and successfully created a second account in Ronin. I sent my 3 axies from an old existing sub ronin account to this newly created (Trezor) Ronin account and the 3 axies was successfully transferred. When I was trying to log in to Axie Infinity, I can’t log in… I tried turning off my computer a few times, clear cache, even to a point of using another laptop.

Then as I was going through the Ronin addresses from inside Trezor, I checked and this particular second account Ronin address in not inside my Trezor. But as you can see, this second account was created when I clicked connect hardware wallet, it even has the Hardware logo beside it. Now I can’t access log on to Axie Infinity to gift it to another ronin account and I can’t access the account as well… Please help, how can I get my Axies back?

Screen Shot 2021-08-08 at 1.00.41 AM

Screen Shot 2021-08-08 at 1.06.45 AM

1 Like

Hi @mitch,

This sounds like a Ronin issue to me. Have you tried contacting Ronin support?
Also watch these two videos:

Yes! I have watched the videos, that’s why the 1st connect hardware wallet was created. I did the same thing for the 2nd connect hardware wallet and I clicked the #2 in Trezor.

What did Ronin support say then?

I have been ignored in Ronin.

Since the problem is that, that particular ronin wallet created now has a hardware sign on it, meaning it needs Trezor approval before logging in, and my Trezor, does that have that particular ronin account, is it possible to add that ronin account into my Trezor so I can access it? Or is it possible to remove the hardware sign on the ronin wallet so I can access without Trezor. I can prove that the account is mine and is currently in my ronin wallet.

same here i’m stuck in this

Same here, setup a main wallet to host and protect slps but cannot access it now. Can transfer im getting a “too many transactions” error. Which does not make sense since other ronin accounts works.

Anyone crakced this?

I have the same experience. I have one ronin address that does not show both on the standard(no passphrase) and hidden wallet(with passpharase). it will not connect to the market place and got stuck.

Any advise?

i have the same issue, after i updated the firmware and recovered my trezor wallet, i cant access my ronin account anymore, even i successfully recovered my trezor wallet.

Hi can anyone help me, i cant recover my trezor account which is connected to my trezor protected ronin accounts. tried using the 18 and 24 seedphrase but the recovery is failed, but with some reasons i can recover the wallet using 12 seed phrase only but the ronin account was not associated with the wallet that was recovered using the 12 seed phrase. i also tried recovering my trezor wallet using the 12 seedphrase of my ronin account but to no avail, the ronin account that i need to access is not connected to that wallet either, is there anyway to locate the private key of the trezor using the ronin address which is secured by trezor? please help, thank you.

same here i cant move asst in ronin address after update

Me too I encountered the same Problem. I thought it is safe to use this trezor but look what happened.
O hope they take serious action about this.

Guys, see here if this can help you.

I have a same problem.

I successfully created a Trezor hardware account in Ronin Welllet.
Login from Axie Infinity Marketplace became normal, and e-mails and passwords were set normally.
But a few days later, I tried to log in with Trezor#1 account, but I couldn’t.
Did I forget PassPhrase?
Not at all. My husband and I saw the same thing and proceeded while checking the same thing. The phrase cannot be wrong.
My husband and I checked the screen and Trezor hardware and confirmed that it was operating normally.
But not now.

I can’t move the AXS in my Trezor #1 account or do staking.

Does it make sense that I can’t access it even though I can see it clearly?

Hi @peunjung
When you connect your Trezor to MEW using the same passphrase can you see following address (0xb30b8170…8f10) on the list of addresses offered to export?

3 posts were merged into an existing topic: How to Recover Trezor Ronin wallet?

No. That address(0xb30b8170…8f10) is not the list of addresses offered to export
I can’t find it anywhere else.

Then you are accessing different wallet than the one where address ronin:b30b8170…8f10 was created.
So you are using either different seed or passphrase or both. (every address is derived from unique combination of those two).

So the result of using different entry then when address was created is that Ronin app is preventing you from spending your funds because (appropriate) private key is missing.
These private keys for signing transactions are also derived from the combination of seed stored on Trezor device and passphrase (if enabled and used).
Hence, if different seed and/or a different passphrase is used then the private key differs and cannot be used.
In such case, previously generated wallets/accounts in third-party apps (such as Ronin) would become watch only wallets without the possibility spending the funds and that is your case as well…