"change address payment credential is a path"

Hey there, I just updated to the latest firmware and when I go to send 1 ADA from my wallet I’m presented with this message on my Trezor. What does it mean?

Thanks

1 Like

I have same issue today after updated latest firmware on model T. Please let me know why this message is showing.

I found this in a help center article about BTC which is based on a similar underlying blockchain model to ADA (UTXO): Change address - Trezor Wiki

Essentially UTXO blockchains operate on the basis of Unspent Transaction Outputs which as a holder of ADA we cumulatively own. Think of them like real cash, but in denominations wholly customisable. When you send 100 ADA to someone, it takes one of your UTXO as input (lets say it has a real value of 3100 ADA attached to it), and then emits two UTXO (think new currency notes): one with a value of 100 ADA that is sent to the receiver, and one with a value of 3000 ADA which is sent back to you via a new “change address” or as in “the blockchain Address for the change from your transaction”, not as in “I am changing my address”.

The article which references BTC states that the creation of these “change addresses” happen transparently on Trezor, but perhaps a change in the latest firmware means that creation of these change addresses for ADA is no longer invisible?

just a theory, but would seem to make logical sense.

@kolin @pavel does this sound plausible?

Thanks

@txxx we are looking into it, I will post an update later

@txxx @kai41314 can you please check your FW version in the settings in Suite and let me know, also is it Adalite wallet, Yoroi or something else?

Try more wallets and let us know if it is the same, post the picture of the error if you can.

Make sure your FW is 2.4.3

@forgi @txxx My FW is 2.4.3. Actually the [“change address payment credential is a path”] message does not show when I tried to send $Ada from Yoroi to another wallet. The message only shows when I tried to withdrawal my staking rewards to same wallet in Yoroi. This message did not appear before the FW update when withdrawal my staking rewards previously.

Also confirm my trezor is 2.4.3. In my case I’m using Yoroi to send ADA to another wallet.

I looked at the trezor firmware on github and I believe the changes that build up this string were introduced into the Cardano handlers here:

as a part of this larger refactor of the Cardano handling code: feat(cardano): add support for script addresses derivation · trezor/[email protected] · GitHub

I’m not able to post photos, but can confirm that following the “Change address payment credential is a path” the path itself is echoed and also found in the cardano code as m/1852’/1815’/0’/1/…

following acknowledging this I am then presented with a “Change address stake credential is a key hash:” message with a key hash I don’t recognise.

following that I am presented with another transaction confirmation message that asks me to confirm the remaining UTXO to be sent to my change address (which I had to look up, but confirm is an internal cardano address to my trezor).

Overall this is a super confusing user experience and one which normal users will rightly so be very worried about.

To repro:

  1. Start a Trezor up on Yoroi (note, looking at the firmware code on github, the software wallet used is likely irrelevant)
  2. Transfer 100 ADA into it in a single UTXO
  3. Stake the 100ADA somewhere
  4. Attempt to send 1 ADA to another wallet
  5. You should see all these messages asking where to send change, confirm stake credentials etc.

Thanks

Having the same issue…

@txxx @kai41314 thanks for the info, it’s a bug in Yoroi. Adalite wallet is using API correctly.

I have opened a GH issue: "Change address payment credential is a path" message on Trezor device · Issue #2575 · Emurgo/yoroi-frontend · GitHub

Hmm - my backup trezor with the older firmware is working fine. So not sure I’d classify it as a bug in Yoroi so much as a breakdown in communication with Yoroi team with the firmware changes Trezor made. As the instigator of the change it falls on the Trezor Product/PS/partnerships team to ensure that all existing integrations are migrated to a breaking API change that Trezor introduced.

In the meantime will use adalite. Thanks for jumping on this fast and providing an alternative!

Can someone help me out here? I have funds stuck on yoroi that I need to move but cannot due to the issue stated above. Is there anything I can do or do i have to wait for an update?

note, that we do not develop or maintain 3rd party apps…the issue has been opened with Yoroi…

ADA will be implemented directly in Trezor Suite very soon

mmmm.

@vidaboa - use adalite