Can't login to Coinmate via Trezor. Is it a Trezor middleware or Coinmate issue?

I was using Trezor as a way to log in to Coinmate from the very beginning.
It was working great, but all of a sudden the feature broke up for me.
When I click the Trezor icon to login from the Coinmate’s homepage ( there appears a TrezorConnect pop-up (url: TrezorConnect | Trezor) and it only shows “Loading…”. It never progress beyond this point.
It does not matter if my Trezor T is actually connected or not.
The web version of the Trezor Suite works OK on the same PC and browser.
I’ve already tried:

  • clearing cache
  • clearing cookies

I would appreciate feedback from the Trezor team.

Hi @nes_luk,

please make sure you have Trezor Bridge installed and try both supported browsers (Chrome and Firefox). Try using Incognito/privacy mode as well.

i have the same issue,any help gotten so far? @nes_luk

Edit: Yes, logging in to Coinmate with Chrome works for me. See more details below.

Yes, I am positive, that I have Trezor Bridge installed, and as I already wrote I am able to use web Trezor Suite just fine. The problem is ONLY with the TrezorConnect middleware when logging in to Coinmate.
Your support page (Trezor Hardware Wallet (Official) | The original and most secure hardware wallet.) also detects my Trezor T just fine:

Firmware: 2.5.1
Transport: Bridge 2.0.27

Yes, I tried two browsers, incognito mode, clearing caches, cookies and none of that helped so far.
Here are browsers that I’ve tried:

  • Firefox 102.0.1 (32-bit)
  • Brave 1.41.96 Chromium: 103.0.5060.114 (Official Build) (64-bit)

I’ve forgot that I have Chrome installed as I stopped using it roughly a year ago.
I tried that just now… AND IT WORKS!
The Chrome got updated probably just after I started it after such a long time and now it shows version 103.0.5060.114 (i.e. the same Chromium version on top of which the Brave is built).

Edit: I tried further with Firefox 92.0 (64-bit) and I managed to log in as well.

Strange that the problem was still there for the other two browsers that I use primarily.
So I was investigating on my own further and played a bit with the browser settings.

I discovered that the following privacy setting has direct impact on the feature:

Simply: the login does not work if this is checked and vice versa.

Strange that I’ve never used “Custom” settings of the Tracking Protection before and I kept the “Standard” all the time. So I guess the protection must have changed with some recent Firefox update.

I will try to check how to optimize the browser settings further.

Anyway thanks for your hints.