Can't create axie account for my trezor ronin address

Hi please I really need help on this one, so this is what happened. I connected and set up my trezor and as seen in Youtube :weary: so after that, I copied the the ronin Id of my trezor ( it say’s hidden wallet in my trezor), I then gifted 1 of my axie to the Trezor’s ronin address. Before I proceed with the transfer, there was a message that says something like “this address in not in the market place” something like that, but I still proceeded thinking it’s normal since I haven’t created an axie account for that Trezor’s Ronin address.

So I finished the transfer, then I was checking my trezor wallet but can’t find my axie there (suite) but 1 axie is showing in my asset (photo attached). Then I have tried to make an Axie Account for this by logging in as the Trezor’s Ronin but the screen is just closing and the account registration is not proceeding, now I can’t play my axie because I have only 2 axie because one is inside my trezor which I can’t access. :sob: :sob: :sob:

please I need help, It’s been 1 week now and I haven’t started playing my axie due to this

Thank you in Advance!

Hi @chellem10,

Since Trezor doesn’t support NFTs, it’s normal that you don’t see them there. As far as I know, Ronin use Trezor as an authenticity tool only and don’t actually transfer Axie pets to Trezor - if you’ve set up the account correctly - it simply shows them inside your Ronin account.

In your image, you can see that 1 Axie shows up as ERC721. Axie pets use the ERC721 protocol, which Trezor doesn’t support. Therefore it’s important to know that you don’t try to transfer Axie pets to Trezor.

See two videos here: Connecting your Trezor to the MetaMask/Ronin wallets for Axie Infinity - #4 by Langly1087
Also, there are many topics about this specific issue, and Ronin issues in general, in these forums.

pretty much everything regarding this topic has already been said in following thread.

they’re on the top portion, I have only snipped the bottom of the Ronin witch shows the trezor’s account

yes this is the problem, I have created the a trezor Ronin address and transfer 1 axie in there without creating a metamask, ( I have watched the videos above, thank you :slightly_smiling_face:) But whenever I make an axie account to my Trezor’s Ronin address I can’t reach this page, (attached photo) as the suite is shutting down by itself. :frowning:

Hey there Chellem,

so I think your issue is that you transferred axies to that ronin trezor wallet, before creating an actual Axie Infinity account with that ronin trezor wallet. :/. This may be an issue that Sky Mavis needs to resolve, because I think it is out of the scope of Trezor’s support.

Have you reached out to Sky Mavis yet in their discord support channel? I will try to do some research myself to see if I can find you a solution.

I show myself logging into Axie Infinity with the Connected Ronin Trezor account towards the end of the video, but I never actually mentioned that it was necessary to do that before transffering axies to it. There have been a lot of people having this simlar issue. I’m going to make another video warning people about this mistake before it becomes a bigger deal.


thank’s for your response, I think this is what actually happened. Now whenever I try to create and account in AXIE the trezor suite is just crushing down ( not proceeding). Im hoping I can still get my axie in my trezor, I’m loosing hope :tired_face:.

1 Like

I believe you should be able to. I’m also going to reach out to the Sky Mavis support line to see if I can get some answers. I feel like it is a bug on their side.

Thank you I will also reach out to axie support I hope they will be able to help me.

Do you solve the problem? I have the same issues and I been struggling for couple month.

Can you help please :sob::sob:

1 Like

same. if Sky mavis support you, please inform. long time ,no response from them.

I just login ronin’s can link with axie game and it have my axie.

The issue was not fixed yet, I ended up buying another aqua for my axie team. I have messaged trezor but still waiting for their reply.