Cant avoid being directed to "New firmware update available" page when trying to send funds

I have an issue where my recovery seed is valid but does not match the one on my device. So I essentially have no recovery seed, only the Trezor device.

The problem now is that I cannot send my funds to another device because I keep getting directed to a page saying " New firmware update available" in chrome. I am using metamask and have the trezor connected, the link it directs me to is TrezorConnect | Trezor
How can I avoid being directed to this page and send my funds?

I also installed the new Trezor Desktop Suite, but am getting this error “Accounts were not loaded properly Ethereum: ui-device_firmware_old”, and again it is asking me to update firmware, but thats not possible as I will lose my funds.

I have read about being in incognito mode to avoid this firmware upgrade page but it hasnt worked for me.

Would appreciate any advice you folks can give.

Hi, try to use this to access your ETH:

Thanks, that’s is a help but I really need the interface through metamask to work as the main dapp I am interacting with uses that wallet. Wish there was a way to just disable that upgrade prompt and not be redirected there every time.

move your ETH away via the link I provided, then wipe the wallet and create new seed and move ETH back

you are running very old FW, and you don’t have seed so it is no possible workaround, we do not develop 3rd party apps.

I have tried using this site to interact with the smart contract but the signed transaction being generated is being rejected, but assuming I get around that, I will try to then move the funds asap.

Every site I interact with always brings me to this trezor firmware popup page, and I cant close/skip it to proceed to the signing transaction stage. The problem is my funds are also locked in the smart contract for a few years so I really need a fix that allows me to skip this popup page. Relaying on these legacy sites has me worried. Also the user guides I wrote for my family are now redundant, I dont know how I will explain this more complicated way of doing things. Passing values to the contract is error prone. My family will only be able to go via Metamask/Trezor so I need that route to work somehow

if you are running old FW from years ago and the 3rd party app updates in the meantime, then yes you are required to update, as I said there is no option to skip it

ETH works fine with legacy mycrypto wallet

In general, the seed should not be required during the firmware update; however, there might be an issue (connection is lost, etc.) and then the device gets wiped and all user data is erased. This is a security feature, in fact, that protects your assets against an attack, for example, one that would try to install unofficial firmware on your device.

When trying to connect my Trezor to, I am now getting a message saying I need to install Trezor Bridge, but it was already installed and connected ok yesterday without this appearing. Is this related to pop ups or add blockers being enabled/disabled or do I need to now be running the Trezor suite instead? Again I cant risk running a firmware upgrade without my keys

  • trezord.exe is running in the background

Because of the Trezor bridge issue, I switched to using the mycrypto desktop app, and that allows me to connect to the Trezor. However I cant send a transaction there either due to an error message “Security Check Failed”, which again seems to be down to some incompatibility. I’ve installed multiple older versions but the same error prevents signing.

I think I need to go back to using Metamask again and find a way to stop this Trezor upgrade popup

install 2.0.27 bridge from here and use legacy mycrypto:

you will keep getting FW popup in MM, your FW is outdated

Using with the v2.0.27 bridge, I’m getting a pop-up saying:

“TREZOR Connect needs the TREZOR Bridge to communicate with your device. Please install the tool from [TREZOR Wallet] and try again.”

Which doesn’t help as bridge is already installed! Do I need to install an old version of bridge (how do I do that if so?) I last used my Trezor in April 2020 (and had the same issue then!)

This issue is so annoying! You should be able to tick a box saying “I want to use my Trezor at my own risk using out of date firmware”, rather than having to run around the country to get your recovery seed every time you want to access funds on your wallet! (Yes, after 9 hours of trying last time, I gave up, updated the firmware and the wallet got wiped). It kind of defeats the whole point of it if it forces you to have your seed to hand.

Try mycrypto desktop app

FW 1.6.2 was released on 25 June 2018 (Firmware changelog - Trezor Wiki), so I would go for mycrypto 1.2.0 releasedon 12 Jul 2018 (Release 1.2.0 · MyCryptoHQ/MyCrypto · GitHub)

If it does not work then try old version of Suite: Release v20.10.1 · trezor/trezor-suite · GitHub