Can't access my fund after formatting windows, even after using the recovery seed

I’ve been using the Hidden Wallet option to store my funds for a while and was able to access it normally, until i formatted windows and reinstalled the app.

I tried to login to the hidden walled with the passphrase but it said the wallet is empty (It’s no, i can see it in etherscan). I tried the following:

1- Factory resetting the hardware wallet to enter recovery phrase and try again. But the same message appeared.

2- I tried to access the standard wallet option that doesn’t require a passphrase to check transaction history… It was empty and there was not history at all.

Would you please support?

I thought it would be solves by entering the private key but clearly nothing was solved.


Hi @gurr,

first, please compare the ETH address you see under your ETH account with ETH address that includes your funds. If the addresses are different, you are in a different wallet. Either you have a different recovery seed stored in your Trezor or you use a different passphrase.

There is a simple way how to verify you use the right recovery seed. You can check that the recovery seed stored in your Trezor device matches your recovery seed backup. Instructions on how to perform this check can be found here:

for Trezor Model One:
for Trezor Model T:

In case recovery seed in your device matches your recovery seed backup, the only way how to access a different wallet (with a different address) is with a different passphrase.