Cannot Find Accounts or both BTC and ERC-20 on Trezor T post firmware update [HELP PLEASE]


After recently updating to the latest Suite (23.4.2) and firmware (2.6.0), I am unable to locate my account addresses for both BTC and ERC-20 respectively. I have my recover seed, and had to use it after dealing with connection issues during the firmware install. I was able to recover my wallet, but once I logged into my standard wallet, I show $0 balances across both. Now it freezes when I must confirm a transaction after the 1st pop up window.

I do not understand. although I don’t consider myself tech savvy in this space, I’m almost certain that this isn’t passphrase related. About a week ago I could swap tokens on an exchange, which requires authorization to confirm. I never created a hidden wallet, and if that were the case wouldn’t I have to sign in to it first before I’m able to confirm erc-20 token-swapping on exchanges?

Please help!! I tried using my recovery seed on a spare Ledger that I own, and I was unable to see any accounts. I tried finding an answer in these forums but no luck. I’m running out of options, and I can’t tell if this is just a software bug or something much worse. I have much of my savings on that address, and I don’t want to lose it!

Any suggestions? Can I roll the firmware back? If I can regain access to those addresses I will gladly move them to a different account number or to an entirely different Trezor.

Have anyone figured this one yet? I have a similar issue after updating to the latest suite 23.4.2, and now I cannot find either BTC nor ETH accounts. And it is not a passphrase issue, I had no problem signing transactions less than a week ago, and I never had to provide a passphrase since I do not have any hidden wallets.

Hi @johnjoe,

is your ETH account enabled? If so and you see a different ETH address under your ETH account, the you are in a different wallet.

If you did not use a passphrase before (you only have a standard wallet), the only way how to access a different wallet is with a different recovery seed stored in your Trezor. Check if your recovery seed backup matches recovery seed in your Trezor. Information on how to perform this check can be found here:

for Trezor Model One:
for Trezor Model T:

Thank you for the speedy reply. In response to your suggestion, I thought of the recovery seed phrase and performed a dry-run recovery test (yesterday) to ensure my wallet checks good. The results were positive: it said the test was successful and my seed matched.

So now given the probability are we suggesting somehow that there’s a passphrase involved? I’m still pretty shaken up about this, because I have no idea what that passphrase would be since it’s such a deliberate action. And the idea of rolling back the firmware to the most recent is out the window?

Still no luck. Some things that I tried:

  • Uninstalled/Reinstalled Trezor Suite, then used recovery seed - same results
  • Cleared cache and rebooted PC - same results
  • Tried re-creating wallet on a spare Ledge Nano that I own - same results
  • Tried to view accounts using another 3rd party wallet (MEW) - same results after viewing 500+ accts
  • Tried to view accounts using another 3rd party wallet (Enkrypt) - same after viewing 7000+ accts
  • Tried changing the order of my recovery seed - results were negative
  • Tried changing some words in seed phrase that could be different words with slightly changed spellings - results were negative

I have the same problem with a trezor model one.

1 Like

@johnjoe and @Boes,

Please answer this question:

See image here.

Yes it is enabled, and I cannot see my public address containing my ERC-20 tokens

Fortunately, after a long time of trying, I have my wallet with content back. I have done the following: I have tried to put the bitcoin only firmware on the trezor. However, this took a very long time and then broke it off. Then put the general firmware on trezor again. Then made the choice for bitcoin, ethereum and ethereum classic. Then I could enter my PIN code and a little later my bitcoin and ethereum appeared in my hidden wallet again.

1 Like

If the recovery seed stored in your Trezor matches your recovery seed backup (assuming it’s the seed that backs up the address that you are looking for) and you see a different ETH address under your ETH account, it is most likely related to the passphrase as it is the only option how to access a different wallet within the same recovery seed.

Is it possible that you created more wallets with different recovery seeds in the past?

Was able to recover my wallet and funds. So here’s a follow-up on what happened:

I reached out to a wallet-recovery service to help recover my funds (you can find several companies online who offer these services), which was nerve-racking for me. In this crypto space trust factor is a premium if it exist at all…so that was a hurdle I had to get over. But once I did and we proceeded to move forward, it took roughly a day to recover my wallet.

Turned out to be a two-fold issue. First, I had a word in my recovery seed that was incorrect, which leads to the next issue. Whenever I tried using my recovery seed to retrieve my wallet, the seed worked but my accounts were missing. Turns out there is a checksum that is supposed to verify the previous seed word in correlation to the following seed word until completion of all 12 words. This checks out because I tried inputting a slightly changed word in my recovery seed during my trouble-shooting, and it successfully rejected my slightly altered recovery seed. But in this particular case it was a DIFFERENT word that was slightly different in spelling…however it “passed” the checksum somehow and accepted the entire recovery seed. This was why every time I thought I successfully recovered my wallet using my recovery seed I saw different accounts altogether. The person who helped recover my wallet explained that this was a very rare case, although entirely possible to happen.

TLDR: Zapped my Trezor during firmware update due to short in usb cable. Using my recovery seed Could not find my accounts. Turned out to be a slightly misspelled word in my 12 word phrase that coincidently passed all checksums gave the false impression my recovery seed worked. A Wallet Recovery Service was able to determine the correct spellings and successfully recovered my wallet and funds. Transferred all holdings to a newly-wiped, fresh wallet. And not once was a “pass phrase” the issue, you can’t “accidently” create one, it is a deliberate action that requires confirmation on your Trezor.