Address unlisted in metamask when connecting with Trezor

Hi Trezor Support team, i am having an issue with my Metamask wallet when i try to connect with Trezor.

This is what is happening:

  1. I have connected Metamask to Trezor Hardware wallet
  2. Selected one of Trezors Metamask Hardware wallets
  3. Changed my desktop and now when i try to set up my wallet in Metamask with trezor , the wallet address is no longer available in the list and it should be.

This is the HW wallet address that it is not on the list anymore 0x2aB6B16EDdc38286d0029d34092A2A124EAD7643

Please help me to understand what is happening because i have all my assets there and now they are not in the list when i try to connect trezor with metamask and it should be.
I have all the account details. What should i do to get my account again in metamask?
Thanks

Hi @nagtomas

If you are not able to access your account - It is not listed after exporting public keys and entering your passphrase (if enabled and used). Then You are accessing different wallet (most probably by mistyping the passphrase)

Mistyping the passphrase will generate a completely new wallet. There is no such thing as an “incorrect passphrase”, so whatever you provide as your input will be used in the process of deriving a wallet and its accounts.

Because of this feature it is crucial to enter exactly the same input in order to access he same wallet including the same accounts having the same addresses in the same order. The public-key cryptography ensures it generates always the same result.

Hi @MichalZ !

I’m having a similar issue to Nagtomas’ but I’ve already checked 5 times and I’m not typing the wrong password.
Would you please jump into this thread and help us out?

Thanks in advance!!

Hi guys, unfortunetly no one from Trezor support team seams to be available to answer our issues what is very disturbing and maybe we need to think if we want to keep this kind of untrustfully service to keep our assets safe in the future.

Nevertheless, i was able to found what was happening in my case (by myself, i repeat, no one from Trezor team answered me so far or help to understand what was happening, instead they pushed me to talk with metamask team which does not make any sense since this is an issue with trezor hw settings).
So when i chose my address created by trezor through metamask account, i didn’t have the passphrase security option turned on in trezor suite. Meanwhile i turned that option on and after that the wallets that Trezor creates are completely different (new ones) and the older simply dissapeared. I turned off the passphrase option again and after that the list changed to the previous one where i had my wallets. Since i have done that the operations are working properly again.

I hope this can help you.

Thanks for providing a solution to your problem. It may help others, who did the same as you.

Well, that’s not quite true, since you got an answer within a day by MichalZ above here. If you had other questions after his reply, you’d be welcome to post more of course.

It’s important to understand what a Passphrase is before you use it or enable the feature. Please don’t blame Community support representatives for your own mistakes. Do your own research and be sure to understand what you do before you do anything. Ask here, in these forums, if you’re unsure what to do or how a feature works.

Hi, thanks for your feedback.
In fact i got support team comment to my issue but it didn’t answer to my question at all as it is happening with the rest of the community that have the same problem or similar to this. If this is a good support team so anyone can do it even someone without any technical formation about trezor…this is not a good support team work at all.
I’ve got a faster answer to this comment where i am trying to help other than when i asked for help to try figure out my and others issue. So it seems that trezor support team is very fast answering when the issues are solved by others but when they are really needed that just doesn’t happen…and when it happens it is just not good enough because it didn’t answer to the question or helped somehow. Everyone can see what i am telling just looking to others users comments like i did…

1 Like

If you’re referring to my reply to you above, know that I’m not part of the Trezor support team. The Community support team is replying as quickly as they can. I’m just helping out where and when I can. Please understand that they have many other people to help too.

Community support also answer you and everyone else as correctly and comprehensively as they can, to try and solve what they think is your problem. However, they can only give you an answer from what information you provide. They don’t see your screen or know what you did, so they rely on you to describe the situation and for providing any relevant information. Community support gives the most probable answer, based on the information they get from you. That answer may not be the right one in your situation, because you did something in addition to what others usually do, but that doesn’t mean the answer they gave you is incorrect for the situation you described in your support request.

Hi @nagtomas ,

thank you for your feedback. My colleague Michal did answer to you and pointed out the issue might be with the passphrase. He would for sure continue troubleshooting your issue, but he never got reply back to what he pointed out. When I read the thread from the very beginning I don’t really see you would continue the conversation asking him to explain it further. You only replied that nobody from support answered your question. Thank you for understanding.