Account not showing in Web wallet

Hello, I’m new to this forum, I just clicked on the Link in my web wallet to have a look at Suite, downloaded it to my computer, had a look around and decided that I actually don’t like the interface at all, trouble is, one of the accounts that was in my web wallet is now only showing in Suite. If I uninstall Suite from my computer, will the account show up in my web wallet?

Hi @RogerP.

It’s because Trezor Suite uses the Bech32 addresses by default (addresses beginning with “bc1”), however Bech32 addresses are not supported in our web Trezor Wallet. Since Trezor Suite is going to replace our web Trezor Wallet in the future eventually, we do not plan to implement Bech32 addresses there.

If you want to see your balance in both interfaces, you are going to need to use either “3” Segwit addresses or “1” Legacy addresses.

However, your funds are totally fine and there is no need to be worried. Feel free to learn more about this topic from our blog post

I am new to these forums, the Trezor and crypto in general. I don’t understand what you mean by Bech32 addresses not being supported by the web Trezor Wallet and how that relates to why some wallets don’t show in the web Wallet. When I plug in my Trezor and go to “” I am asked for my PIN on the device and then prompted for a passphrase via the website. I created two hidden wallets when first setting up the device, but only one of the passphrases to one of the wallets works and when I enter in that passphrase I don’t see any funds there… I can only gain access to the other hidden wallet I created if I use the Suite app. Why would the website prompt me for a passphrase when it seems only certain passphrases to certain wallets will work? How can I create a hidden wallet with a passphrase so that I can see it via the web wallet? Is this even possible? What if I’m trying to access my funds and I can’t download the software, am I out of luck?

Hi @Paul

Trezor Suite supports all three types of addresses (BTC accounts):
Legacy beginning with 1, Segwit beginning with 3, Native Segwit beginning with bc1

Trezor Wallet, on the other hand, supports only:
Legacy beginning with 1 and Segwit beginning with 3

Basically, when the same recovery seed is used and the same passphrase is entered (if enabled and used), the same wallet is accessed. There is no exception. It always generates the same wallet including the same accounts having the same addresses in the same order. The public-key cryptography ensures it generates always the same result.

Please note, passphrase is case sensitive and space is a valid character as well. Passphrase is a feature that enables you to create as many hidden wallets as you need to. Once you enter the same passphrase, the same wallet is accessed. However, if you enter a different passphrase, you create a different wallet. This is why there is no such thing as a wrong passphrase. Since default wallet is passphrase non protected, just leave it blank to access your default wallet.

To sum it up, by using and entering the same seed (and passphrase) you always get the same wallet, containing the same accounts with the same addresses despite the fact what that particular app enables you to access (e.g. different types of account might be supported, limited nr. of accounts etc.).

Thanks for response but this still doesn’t make sense. When I access my Trezor wallet on a regular basis, I am never entering my seed phrase or recovering the wallet. I am simply asking that when I access Trezor Wallet, why does it ask for a passphrase at all? I see the main point of using a passphrase is to allow you to have multiple wallets. Consider the situation where I’ve created 15 different passphrases thus creating 15 different wallets, would only ONE of those passphrases work with Trezor Wallet? Which passphrase would that ONE be? Do I have to remember which one of the passphrases work or would I have to randomly guess all 15 until the system lets me in? Would I have to use the Trezor Suite to use any of the other 14 passphrases? And also when I do access Trezor Wallet with a passphrase that is recognized why do no funds show up in the wallet that passphrase is for and why can I only see the funds in the Trezor Suite? I would imagine that almost any crypto investor is going to invest in multiple coins thus necessitating the need for multiple wallets and in that scenario Trezor Wallet is useless for the majority of investors? In addition even if you only have 1 passphrase which is entered correctly and the system recognizes this, Trezor Wallet still doesn’t show you any funds in that wallet… Which begs the question, why do you even offer this and instruct users to access their funds with Trezor Wallet when setting up the device?

Once the passphrase is enabled and set up, then this particular wallet can be accessed anytime by any app enabling to use such feature (passphrase is supported by both Trezor Wallet and Trezor Suite).

Speaking of passphrases, you must remember them all as they are not stored anywhere.

When a passphrase protected wallet is accessed (with the same seed) then the same wallet is accessed no matter what app is used. However, within this wallet there might be accounts not accessible by some apps, e.g. BTC bech32 accounts, as previously explained.