Account not found during setup "select an account"

Hello All, I am unable to import my MM Wallet, my address doesn’t show up during the select
an account portion of the setup. I cannot get past this part my address isn’t there.

You did not express the problem clearly.
Whether to use mm to create a mm-trezor wallet, or use mm’s seed to restore trezor.

Either way Ive tried both. Once the trezor has a seed phrase set the same same thing occurs in MM. Ive restored trezor with meta mesk seed phrase from my wallet and Ive tried from the trezor app using a random seed generate from trezor suite… in the next step connecting to MM to download wallet is where the issue is. I go to connect a hardware wallet in Meta Mask in and in both cases My hot wallet address is not displayed and cannot be selected from the listed addresses.
Does that make sense?

if you cannot find the address in the list, you are most likely using wrong passphrase

Is the passphrase I should be using the one set for the trezor or the passphrase for the MM wallet?

the passphrase from Trezor

Thats the passphrase I have been using .

if the addresses are different and balance is zero, then you are not using the correct one…sorry there is no other way around it

also, make sure you not mixing up something going back and forth between metamask seed, trezor and recovering on one and other.

Plus, some people mistake passphrase for PIN, or the browser auto fills the passphrase

Still not working… I see my eth coin balances in trezor suite form my MM. But still cannot send out from the hardware walled on MM.

If you are looking for address from Trezor, you need to have Trezor seed loaded on the device and use correct passphrase and connect via “Connect HW wallet” option in MM.

Once you initialize MetaMask wallet, there is a default account created (the red one in the picture). If you wish to use it, then you need to keep your MetaMask seed phrase to recover and access this account whenever needed. This account is not a part of Trezor wallet.

On the contrary, there are Trezor accounts (the yellow and the blue one in the picture). The same accounts are generated in MEW, Trezor Suite etc. These are Trezor generated accounts and can be recovered only by using Trezor recovery seed.

Basically, the explanation of your issue is that the particular address (account) you refer to is not part of your (current) Trezor Wallet. Even though Trezor is not connected, in MetaMask you can still see;

  1. your default MetaMask account,
  2. also your previously used Trezor generated wallet(s) with different seed(s),
  3. and also your Trezor generated wallet(s) with passphrase(s)

All three wallets mentioned (1, 2, 3) would differ from your currently used Trezor Wallet. Only the first MetaMask account (1) you can use without your Trezor because it’s independent on Trezor completely.

However, as for other accounts (2, 3) you may see, the related Trezor wallet must be connected (either with the appropriate seed and/or with the appropriate passphrase). Otherwise, you wouldn’t be able to sign any transactions within these accounts due to missing the appropriate private key stored on Trezor. And that’s when it gets frozen.

Im having the same issue I also have the recovery seed for the Trezor wallet. How do I regain the trezor-generated account I need ( similar to the one in yellow) if I didn’t use a passphrase when it was created? Also in the 3rd pic I see that you are able to change the HD derivation path, is that something I can do to retrieve the account I need?

you have to leave the fields empty when asked for passphrase, then click the green button to enter the wallet, you will ger the list of addresses form your standard wallet