Accessing ETH on MEW with Trezor

Long before Trezor Suite existed I used MEW with my Trezor to store ETH. I last successfully verified my ETH balance about a year ago, maybe a little more. But yesterday I went to look and I can’t find my ETH. Instead, I’m confronted with what seems is an endless amount of addresses with zero balances.

I downloaded and installed the Trezor Suite, and my other coins (BTC and LTC) show up just fine on there. The ETH does not.

It’s not clear to me if the ETH should automatically show up, or if I need to transfer it from MEW. But if I need to transfer it from MEW I don’t see how I can because I can’t find it when I use either of their wallet versions (I’ve tried v5 in addition to their current one).

I can’t figure out if this is a problem with MEW or with m Trezor. This may not help, but FWIW I do recall that when I accessed my ETH on MEW, I did have to look through a couple drop downs and it wasn’t in the most obvious spot. It was like there was a secondary dropdown menu or something. I never took screenshots of the exact names because I didn’t figure it would change so much, and that, so long as my Trezor was secure, I’d always be able to access it. Welp!

My trezor has always been secure, I haven’t bought any new crypto or downloaded any new crypto apps, or engaged in any activity that would have exposed my passwords or seed. I also have the address to which my my ETH was transferred, and Etherscan shows it’s still there.

I’m wondering if my ETH was stored using some derivation path that is no longer considered standard since I transferred it (in 2017). I see there is a website called FindETH.IO that represents itself as a safe tool for searching through multiple derivation paths, but I’m wary of connecting my wallet to it.

Hi @whichlife5413

If you are accessing the wallet with no transaction history or you are not able to find desired address in the ETH wallet (even with tool) then you are accessing wrong wallet.

Because when the same recovery seed is used and the same passphrase is entered (if enabled and used), the same wallet is accessed. There is no exception. It always generates the same wallet including the same accounts having the same addresses in the same order. The public-key cryptography ensures it generates always the same result.

Simply put you must have previously created the receiving address in different wallet (probably passphrase protected one) than you are accessing now.

So the question is: Have you recently started to you passphrase feature/ did you use it in the past?

Please note that once the passphrase feature is activated on the device, you can provide any input of your choosing and it will be used to generate a completely new wallet. To access this hidden wallet repeatedly, you will have to use the exact same passphrase in combination with the recovery seed on the device.