Access passphrase wallet in metamask

hi all, i have existing trezor wallet linked to my metamask and it’s working great

i setup a passphrase to create a hidden wallet. how do i access that hidden wallet via meta mask ?

thank you

After you click on Connnect Harware Wallet:
image

And export public key:
image

you will be asked to enter your passphrase as a next step:
image

Thank you . I can’t seem to get it to request export public key. How do I do that?

Appreciate your help

Simply follow this manual:
https://metamask.zendesk.com/hc/en-us/articles/360020394612-How-to-connect-a-Trezor-or-Ledger-Hardware-Wallet .

hey @MichalZ i was able to do this on a freshly setup metamask. but i can’t seem to do this on what i have setup and connected to my “Non” passphrase wallet.

any tips on how to add it to the existing wallet

if not all good i can just access it with this secondary account

thanks

sorry i worked it out. i have to reset the trezor! thank you

Hi @MichalZ , can I still add passphrase on an existing standard trezor wallet? or if I add one, it will only create a new wallet. Thank you

Hi @jssamonte by enabling passphrase you would create a new wallet.

Please note, passphrase is case sensitive and space is a valid character as well. Passphrase is a feature that enables you to create as many hidden wallets as you need to. Once you enter the same passphrase, the same wallet is accessed. However, if you enter a different passphrase, you create a different wallet. This is why there is no such thing as a wrong passphrase. Since default wallet is passphrase non protected, just leave it blank to access your default wallet.

No you can’t… as Pavel said it only creates new wallet.
Everything in your wallet (its accounts and addresses) is being derived from your recovery seed.
The derivation is as follow:
Recovery seedAccount private keyPrivate keyPublic key → Address

And very simply put you can imagine your unique passphrase as a 25th/13th word of your mnemonic phrase. So you can’t just “additionally protect” the wallet and its addresses that has already been used.

If you have some funds in your standard trezor wallet and you want to add that extra layer of security (your passphrase) simply create new wallet by using this feature and transfer your funds over there :wink:

I can get to the screen to export public key but after I click “Export” it doesn’t ask me to enter passphrase, for me. I have 2 wallets, one with passphrase and one without. It always just reads the wallet without passphrase.

Hi MichalZ, I’m experiencing the same challenge. Did you solve this problem or get an answer?

Do you have the passphrase feature enabled in your device settings in Trezor Suite ?

I previously connected my trezor T on my MM, and transfer my funds in the Hardware wallet account on MM. however my pc broke and had to buy a new one… now i was able to retrieve my metamask through seed phrase however when im trying to connect my trezor… I CANT FIND THE ADDRESS Where my funds are located… i tried turning off the passphrase and turning it on nothing changes on the addresses selections its giving me… please someone help… i have not reset or do anything with both of my MM and trezor… i cant find my address where my funds are please someone help

Hi @SaiTarpian

If you don’t see the desired address in the list offered, you are using different combination of recovery seed and passphrase than you did when you created the address you are trying to access in the first place (thus you are accessing different wallet).

Imagine recovery seed altogether with unique passphrase as some sort of magic formula that always let you access the same wallet. If one of them differs it will lead you to different wallet (with different addresses, which is your case as well),

Well first off, don’t give up.
So, you have your Trezor secret phrase and MM secret phrase?
Did you have different accounts on MM?

I have the same problem, what´s the solution? I have deactivated passphrase since it´s so confusing what that means - Call it seed phrase and password instead, wtf is passphrase was my initial reaction!? Now my assets has been stuck in my TREZOR since I sent them there 24 days ago and I´m so disappointed of the help I´m able to receive. One or two answer than stop. I´m going to throw my 3 Trezors I´ve bought in the fire as soon as I have retrieved my money! I´m furious, I haven´t been able to rescue over 50% of my portfolio from this dip and that´s over a years average income in Sweden!!

I am also having the same problem after I remove the metamask extension because it lagged later on my trezor wallet address didn’t show up to “connect hardwallet” this my address please help me 0xeDdCd6f7D18c0257f5703Ac258c0b8cC0d45e966

Word of advice - never use any function until you have read about it and know how it works. This is especially important when it comes to hardware wallets like Trezor.

122180 that is my ticket number please help me sir