Acces Trezor T wallets on multiple Laptops

I have my Trezor T suite setup on my own laptop and that seems to be working fine. Now I also want to setup the suite on my wife’s laptop to access the wallets so she can use it when I am not home as I travel a lot for work.

After installing the suite on her laptop my default wallet showed up empty instead of filled with the coins I have.
Is it even possible to set it up in this way or can you only reach it on one machine at the same time.

Thanks in advance for any advice

Hi @Randy
You have to connect your device to the newly installed wallet interface to be able to see your balance, transaction history and so on.
Then you can use “remember device” feature to watch over your balances in Trezor Wallet without having to plug in your Trezor.

What’s happening is that the app has your extended public key (aka xpub), which enables generating receive addresses and balance viewing. You can give anyone your xpub without risk to your bitcoins (though note they will be able to follow all transactions you make with the wallet).

To sign transactions and send bitcoin requires private keys. These are generated on the device (from the wallet seed). So if your device is not connected to your computer, the app cannot make any transactions.

Thanks MichalZ. This worked

Hi MichalZ

When I connect my device to the newly installed interface on my second laptop it does not show the wallet on the device or the accounts and instead asks whether I want to create a new standard wallet or passphrase.

Am I missing a step in installing the new interface on my second laptop?


Hi @atticus
yeah that is expected behavior as the passphrase feature is enabled by default.
And it is not asking you which wallet you want to create but which one you want to access.

So if you want to access the same Hidden (passphrase protected) wallet, you have to enter exactly the same passphrase, on the other hand if you would mistype the passphrase it actually automatically creates new hidden wallet (that’s how the passphrase feature works).

And if you want to access default wallet (without passphrase protection) simply proceed to Standard wallet.

Thanks MichalZ

When I accept standard wallet, as this is what is set up on my Model T, it takes me into the interface but shows no accounts even though the Model T its connected. It appears to take me to the setup of a new wallet. Any thoughts?

Your help is really appreciated!

Actually MichalZ I just found my problem.

All I needed to do was activate the other crypto in the interface!

Thanks again for your help!!

yeah not all the account are activated by default.
Anyways, I am glad that your issue has been resolved :wink: