About the Technical issues category

Can’t connect your Trezor? Do you have questions about firmware upgrades? Ask here.

A post was split to a new topic: Připojení Trezoru na Android

Hi. i recently bought a trezor T model. i’m trying to send my BTC to trezor wallet. but it always gives me invalid addresses, and i can’t send my funds from coinbase to trezor wallet. does anyone know why?

After i click confirm on Meta Mask, when im redirected to the Trezor Web suite to sign ethereum transaction the page just keeps saying loading. I’ve tried clearing the cache and check for updates but everything is up to date. It was working fine yesterday but today it just stopped working. Any suggestions?

I’ve opened a support ticket with #86579

Hello guys!

I connected my new Trezor One to Trezor Suite on Tails OS (took me two days to figure out how to do it…) and during the initial set-up phase I bumped into an error while downloading a firmware update (probably because of the Tor connection or so).

The only way to solve it was to find the firmware online and install it manually. I did it successfully, however the only one I found was ‘Bitcoin Only’ firmware.

My question is: is it possible to change the ‘Bitcoin Only’ firmware to ‘All Coins’ standard one? Maybe there is a way to download it somewhere and install manually via Terminal commands?

Model: Trezor One
Firmware version: 1.10.2
Software: Tails OS (Linux Debian)

Thank you!

I would like to connect my device on a VPS running Windows. My device (a T) won’t work. I installed both the Suite and the Bridge. I made sure I was using Chrome. The device works when I’m not using the VPS. Can somebody explain why this is and if there is a solution? I would really prefer to use my device on the VPS. Thanks.

I had the similar problem. Unboxed Trezor Model T and began setup. It kept failing over and over again saying the device disconnected or “Error 19.” I disconnected my VPN (not VPS like you) and it worked on the first attempt.

Hi. Please help me. I can’t connect my trezor T via web trezor suite. This is what I see on my display:

Error occurred
It appears something is broken. You might let us know by sending report
navigator.registerProtocolHandler is not a function

hi,i got my new trezor one and when it was upgrading firmware on first time use ,it asked me to disconnect and connect it,on reconnect trezor stops responding nothing on screen and not detected on windows.i’ve tried everything(change usb port,change cable,registry modify,zadig,bridge,etc…)nothing works.it’s like dead.
Ticket ID: 104205

1 Like

Hi,

After creating a Ronin Wallet for Axie Infinity, a friend of mine connected the Trezor through “Connect Hardware Wallet” function. He was able to get to the part where he can see the 50 wallet addresses.

Now, he sent SLPs from Binance to the #1 wallet address that is listed on Trezor list of 50 wallets. He changed the “ronin:” prefix to “0x” and selected RON as the network. Binance also confirmed that he successfully withdraw the SLPs and sent to that #1 ronin address listed on Trezor .

When he opened up the Ronin wallet on his Chrome extension, there is only 1 account showing up on Ronin Wallet and it was the default Ronin wallet address that was created and generated when he first created his Ronin, but where he sent the SLP is in the Trezor’s #1 ronin wallet address which is not showing along with the other 49 addresses…

He tried to connect Hardware Wallet again but after he entered the PIN, Passphrase and press confirm on the Trezor device, he always get the error message saying “something went wrong, try again.” He also mentioned that there are INACTIVE DEVICES showing up on the screen and it says click to activate, but when he clicks it, he also gets the same error message saying “something went wrong try again.” I hope you have an idea of what is happening.

i’m trying to connect for the first time my trezor to my chromebook!

but i always have this problem

Screenshot 2021-11-10 18.55.37|690x356

Your device is connected properly, but your internet browser can not communicate with it at the moment. You will need to install Trezor Bridge.

When trying to set up new Trezor Model T, I’m getting a Security Check message that says firmware already installed and “Something seems off. Contact support.” I originally got interrupted during setup and do not recall having done anything other than plug the unit in. I pretty sure I did not install the firmware. However, I’m not 100% sure & want to be completely safe by reloading the firmware. A user advised me to wipe the unit, which I did, but that does not wipe the firmware, only the data & seed. I’m still getting same firmware message mentioned above. Have not gotten replies to my topic on this, so it appears others don’t know how to do it either.

How can I re-install the firmware to be sure that there wasn’t a pre-existing firmware load before I got the device? Thank you!

Hi @Tannhauser00, Unfortunately, Chrome OS is not officially supported: https://wiki.trezor.io/Supported_operating_systems
It should work in a Chrome browser though - try to update to latest firmware version on another computer with a supported setup first.
However, to guarantee a functionality of our products, I suggest using Trezor on a computer with a supported operating system.

Hi @Bluehead, you can connect to Trezor Suite only if the firmware is correctly signed by SatoshiLabs, because the bootloader verifies the firmware signature each time you connect your Trezor to a computer. Therefore, you don’t have to worry that there is malicious firmware installed.
If you want to factory reset the device, connect Trezor to a computer in a bootloader mode, visit https://wallet.trezor.io/#/ and select the Factory reset option.

Hi @Moonlight_CSE, it seems your friend is not using a correct private keys (seed+passphrase, if used), as one set of private keys always leads to the same addresses. If the private keys changed, addresses within the wallet change as well. You can tell your friend to submit a ticket at https://trezor.io/support/technical/issue/ and we will do our best to help him out.

@NIYAK Thank you very much for explaining this to me. I’m not a techie, so it’s critical for me to understand the difference between the firmware and the data that can be wiped in order to know that I’m using it securely. Appreciate the info! Cheers.

FATAL ERROR
RSOD - func: touch_power_on
Is there no simple fix for this?